<!DOCTYPE html> <html lang="en-US"> <head> <script>var pb_global={pageName:"article-template",pageId:"rHJ9vP1Xz0ktKr",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"wxix"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>
  var RCdataLayer = [{
    "adTarget": "wxix/web/sports/nfl/browns",
    "authors": [
                  
                    {
                      "_id": "john-deike",
                      "name": "John Deike",
                      "type": "author"
                    },
                  
                ],
    "canonicalUrl": "/2020/02/20/ex-cleveland-browns-lineman-greg-robinson-caught-with-pounds-marijuana-near-mexican-border-authorities-say/",
    "contentId": "YXYDB6KWFVEXJOH36P5UZYWFLI",
    "contentName": "Ex-Cleveland Browns lineman Greg Robinson caught with 157 pounds of marijuana near Mexico border, authorities say",
    "contentOwner": "woio",
    "contentTags":  [
                  
                ],
    "contentType": "story",
    "datePublished": "2020-02-20T02:46:33.831Z",
    "description": "Former Cleveland Browns offensive lineman Greg Robinson and ex-NFL player Jaquan Bray were arrested near the El Paso-Mexico border on Monday evening, after authorities found 157 pounds of marijuana in an SUV the pair was traveling in.",
    "distributorCategory": "staff",
    "distributorMode": "reference_denormalized",
    "distributorName": "Gray TV Stations",
    "distributorReferenceId": "dee592ee-659e-4038-a289-0bfe818887ca",
    "distributorSubCategory": "gray-original-content",
    "hasVideo": "false",
    "metaDescription": "Former Cleveland Browns offensive lineman Greg Robinson and ex-NFL player Jaquan Bray were arrested near the El Paso-Mexico border on Monday evening, after authorities found 157 pounds of marijuana in an SUV the pair was traveling in.",
    "platformName": "Arc Feature Pack",
    "primarySection": 
                        
                        
                          
                          {
                            "name": "Cleveland Browns",
                            "_id": "/sports/nfl/browns",
                            "path": "/sports/nfl/browns",
                          }
                        
                      ,
    "publishedDay": "19",
    "publishedMonth": "02",
    "publishedYear": "2020",
    "stationName": "wxix",
    "timezoneOffset": getTimezoneOffset(),
    "userAgent": navigator.userAgent,
    "userId": "",
    "userTimezone": Intl.DateTimeFormat().resolvedOptions().timeZone,
    "userTimezoneTimestamp": new Date()
  }]

</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="4l7NiX4H2XPUFBLqBGb3Ax7N1gI-hyEUij2m-EmqW0o"/> <title>Ex-Cleveland Browns lineman Greg Robinson caught with 157 pounds of marijuana near Mexico border, authorities say</title> <meta name="keywords" content="greg robinson, jaquan bray, marijuana, el paso, drug bust, cleveland browns"> <meta name="news_keywords" content="greg robinson, jaquan bray, marijuana, el paso, drug bust, cleveland browns"/> <meta name="date" content="2020-02-20T04:47:51.257Z"/> <meta itemprop="description" name="description" content="Former Cleveland Browns offensive lineman Greg Robinson and ex-NFL player Jaquan Bray were arrested near the El Paso-Mexico border on Monday evening, after authorities found 157 pounds of marijuana in an SUV the pair was traveling in."/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="https://www.fox19.com/2020/02/20/ex-cleveland-browns-lineman-greg-robinson-caught-with-pounds-marijuana-near-mexico-border-authorities-say/"> <meta name="twitter:title" content="Ex-Cleveland Browns lineman Greg Robinson caught with 157 pounds of marijuana near Mexico border, authorities say"/> <meta name="twitter:image" content="https://www.fox19.com/resizer/QEDqSfiEDAFdkT5tOoBRKa9Ejww=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/F2F5CEEO6JCS7MQBJNGRXOYQQU.jpg"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="Former Cleveland Browns offensive lineman Greg Robinson and ex-NFL player Jaquan Bray were arrested near the El Paso-Mexico border on Monday evening, after authorities found 157 pounds of marijuana in an SUV the pair was traveling in."/> <meta name="twitter:site" content="@FOX19"/> <meta name="twitter:creator" content="@FOX19"> <meta property="og:url" content="https://www.fox19.com/2020/02/20/ex-cleveland-browns-lineman-greg-robinson-caught-with-pounds-marijuana-near-mexico-border-authorities-say/"/> <meta property="og:title" content="Ex-Cleveland Browns lineman Greg Robinson caught with 157 pounds of marijuana near Mexico border, authorities say"/> <meta itemprop="image" property="og:image" content="https://www.fox19.com/resizer/QEDqSfiEDAFdkT5tOoBRKa9Ejww=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/F2F5CEEO6JCS7MQBJNGRXOYQQU.jpg"/> <meta property="og:description" content="Former Cleveland Browns offensive lineman Greg Robinson and ex-NFL player Jaquan Bray were arrested near the El Paso-Mexico border on Monday evening, after authorities found 157 pounds of marijuana in an SUV the pair was traveling in."/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="https://www.fox19.com"/> <meta property="og:type" content="article"/> <meta property="fb:app_id" content="380559952020519"/> <meta property="fb:pages" content="170473136030"/> <meta property="fb:admins" content="644426401"/> <meta name="burst" content="WXIX"/> <meta property="article:publisher" content="https://www.facebook.com/FOX19Cincinnati"> <link rel="amphtml" href="/2020/02/20/ex-cleveland-browns-lineman-greg-robinson-caught-with-pounds-marijuana-near-mexico-border-authorities-say/?outputType=amp"> <meta name="author" content="John Deike"> <script data-schema="NewsArticle" type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": ""
        },
        "headline": "Ex-Cleveland Browns lineman Greg Robinson caught with 157 pounds of marijuana near Mexico border, authorities ",
        
        "image": {
          "@type": "ImageObject",
          "url": "https://www.fox19.com/resizer/QEDqSfiEDAFdkT5tOoBRKa9Ejww=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/F2F5CEEO6JCS7MQBJNGRXOYQQU.jpg",
          "height": 1601.0,
          "width": 1200
        },
        
        "datePublished": "2020-02-20T12:28:35.541Z",
        "dateModified": "2020-02-20T04:47:51.257Z",
        "articleBody": "EL PASO, Texas (WOIO) - Former Cleveland Browns offensive lineman Greg Robinson and ex-NFL player Jaquan Bray were arrested near the El Paso-Mexico border on Monday evening, after authorities found 157 pounds of marijuana in an SUV the pair was traveling in.Robinson, 27, and Bray, 26, were driving from Los Angeles, Calif. to Louisiana when they hit a border patrol checkpoint in El Paso, according to court documents.A drug-sniffing dog reportedly alerted authorities to the illegal drugs stashed in the 2020 Chevy Tahoe at the Sierra Blanca Checkpoint Station.A criminal complaint filed by U.S. attorneys alleges that Robinson and Bray were “conspiring to possess with intent to distribute marijuana.”Authorities found the drugs in several large duffel bags stacked in the back of the SUV.The complaint also stated that Robinson rented the Tahoe in Los Angeles on Sunday and had arranged for an Uber driver to drive him and Bray to Louisiana. When the trio reached El Paso, Robinson instructed Bray to begin driving.According to the complaint, when they approached the Sierra Blanca checkpoint, Robinson asked the Uber driver to claim the marijuana, but they reportedly refused.If convicted, Robinson and Bray face up to 20 years in prison.Return to 19 News for updates on this developing story.Copyright 2020 WOIO. All rights reserved.",
        "author": [
          
            
              
                {
                  "@type": "Person",
                  "name": "John Deike"
                }
              
            
            
          
        ],
         "publisher": {
        "@type": "Organization",
        "name": "WXIX",
        "logo": {
          "@type": "ImageObject",
          "url": "https://www.fox19.com/pb/resources/images/rm_icons/wxix-icon.png?token=123",
          "width": 467,
          "height": 60
        }
      }
        },
        // will be empty for branded publishing
        "description": "Former Cleveland Browns offensive lineman Greg Robinson and ex-NFL player Jaquan Bray were arrested near the El Paso-Mexico border on Monday evening, after authorities found 157 pounds of marijuana in an SUV the pair was traveling in."
      }
    </script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "WXIX",
        "url": "https://www.fox19.com",
        "logo": "https://www.fox19.com/pb/resources/images/rm_icons/wxix-icon.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://www.facebook.com/FOX19Cincinnati" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-framework96cfbfc61ff908bdad44.css?v=89" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/wxix-logo.svg?v=89)}.logo.logo-footer{background-image:url(/pb/resources/images/footer_icons/wxix-logo.svg?v=89)}</style> <link href="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-framework96cfbfc61ff908bdad44.css?v=89" rel="stylesheet"/> <link href="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-features96cfbfc61ff908bdad44.css?v=89" rel="stylesheet"/> <link href="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-services96cfbfc61ff908bdad44.css?v=89" rel="stylesheet"/> <script src="/pb/gr/c/default/rHJ9vP1Xz0ktKr/arcAdsJS/cdbd7d78da.js?v=89"></script> <script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> <script src="//cdn.connatix.com/min/connatix.renderer.infeed.min.js" data-connatix-token="a562e44c-8ee3-43a2-8237-95cf454dd8c8" async></script> </head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> </head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative zindex-higher col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="faYVSr1Xz0ktKr"> <div id="sales-nav" class="background-grey-minimal visible-lg"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.fox19.com/live/" class="color-grey-dark">Watch FOX19 NOW Live</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.fox19.com/contests/" class="color-grey-dark">Contests</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.fox19.com/business/business-spotlight" class="color-grey-dark">Business Spotlight</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://41919deals.revrocket.us/" class="color-grey-dark">41919 Deals</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.fox19.com/health/cancer/19-for-a-cure" class="color-grey-dark">19 for a Cure</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.fox19.com/story/33998556/adoptable-pets-across-the-tri-state/" class="color-grey-dark">Take Paws</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.fox19.com/skyfox19/" class="color-grey-dark">Sky FOX19</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.fox19.com/2019/12/27/fox-now-xtra-coffee-talk/" class="color-grey-dark">Coffee Talk</a></li> </ul> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" id="f0aKfloXz0ktKr"> <style>.pb-f-article-body .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 200px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}.pb-f-article-body .card .img-container.width-full,.pb-f-article-header .card .img-container.width-full{background-color:#f9f9f9}.pb-f-article-header .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 150px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}</style> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky zindex-higher col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="f0ExsO8Xz0ktKr"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.fox19.com"> <div class="logo logo-slim"></div> </a> </div> <div class="app-bar-top-container flex-3 flex-container-row relative spaced spaced-sm spaced-left spaced-right hidden-sm"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.fox19.com/video-gallery/" class="">Video</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/programming/morning-show" class="">Morning Show</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.cincyweekend.com/" class="">Cincy Weekend</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.fox19.com/about-us" class="">About Fox19 Now</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div class="app-bar-tray" data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full zindex-high tray-open visible' : 'tray left-0 hidden width-full zindex-high hidden'" class="tray left-0 hidden width-full zindex-high"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <div class="flex-grid"> <div class="tray-section tray-section-1 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/homepage" class="color-white">Home</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.fox19.com/live/" class="color-white">Watch FOX19 Live</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/programming/schedule" class="color-white">Programming Schedule</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/community/user-content" class="color-white">Submit photos</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="http://www.fox19.com/apps/" class="color-white">Fox19 Apps</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="https://www.fullcourtgreta.com/" class="color-white">Full Court Press with Greta Van Susteren</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="http://www.circleallaccess.com" class="color-white">Circle - Country Music & Lifestyle</a> </div> </div> </div> </div> <div class="tray-section tray-section-2 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/news" class="color-white">News</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/news/state" class="color-white">State</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.fox19.com/news/butler-county/" class="color-white">Butler County</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://www.fox19.com/news/warren-county/" class="color-white">Warren County</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="https://www.fox19.com/news/northern-kentucky/" class="color-white">Northern Kentucky</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="https://www.fox19.com/news/indiana/" class="color-white">Indiana</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="http://www.fox19.com/video-gallery/" class="color-white">Video</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="https://www.fox19.com/skyfox19/" class="color-white">Sky FOX19</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="/news/rob-williams-anytime" class="color-white">Rob Williams Anytime</a> </div> </div> </div> </div> <div class="tray-section tray-section-3 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/weather" class="color-white">Weather</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.fox19.com/weather/forecast/7-day/" class="color-white">7-day forecast</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="http://www.fox19.com/weather/closings-delays/" class="color-white">School closings and delays</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/weather/cams" class="color-white">Weather Cams</a> </div> </div> </div> </div> <div class="tray-section tray-section-4 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/sports" class="color-white">Sports</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/sports/high-school" class="color-white">Final Quarter Sports</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/sports/scores" class="color-white">Scores</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/sports/wake-up-call" class="color-white">Morning Wake Up Call</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/sports/athlete-of-the-month" class="color-white">Penn Station Athlete Of The Month</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/sports/high-school/game-of-the-month" class="color-white">Game of the Month</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/sports/high-school/play-of-the-week" class="color-white">Play of the Week</a> </div> </div> </div> </div> <div class="tray-section tray-section-5 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/programming/morning-show" class="color-white">Morning Show</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/traffic" class="color-white">Traffic</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="http://www.fox19.com/join-the-fox19-now-birthday-club/" class="color-white">Birthdays on Fox19 Now</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/food/recipe" class="color-white">Recipes</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/health/cancer/19-for-a-cure" class="color-white">19 For A Cure</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="http://www.fox19.com/story/33998556/adoptable-pets-across-the-tri-state/" class="color-white">Take Paws</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="https://www.fox19.com/2019/12/27/fox-now-xtra-coffee-talk/" class="color-white">Coffee Talk</a> </div> </div> </div> </div> <div class="tray-section tray-section-6 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/business" class="color-white">Business</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.fox19.com/business/business-announcements/" class="color-white">Business announcements</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/business/home-pros" class="color-white">Home Pros</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/business/business-spotlight" class="color-white">Business Spotlight</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="http://www.fox19.com/business/paid-programming/" class="color-white">Paid programming</a> </div> </div> </div> </div> <div class="tray-section tray-section-7 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/about-us" class="color-white">About Us</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.fox19.com/2018/09/26/meet-fox-team/" class="color-white">Meet the FOX19 team</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/community/calendar" class="color-white">Calendar</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="http://www.fox19.com/apps/" class="color-white">Fox 19 Apps</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="http://www.fox19.com/about-us/smart-devices/" class="color-white">Smart Device Central</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="http://www.fox19.com/about-us/digital-advertising-solutions/" class="color-white">Digital Advertising Solutions</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="http://www.fox19.com/story/3878720/cincinnati-tv-internships-at-fox19-wxix/" class="color-white">Internships at FOX19</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="https://gray.tv/careers#currentopenings" class="color-white">Job Postings</a> </div> </div> </div> </div> </div> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0MEpCZXz0ktKr"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-wxix-breaking/" data-url="/pb/api/v2/render/feature" data-website="wxix" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="fZgFpz1Xz0ktKr"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/wxix-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="wxix"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fOcnHR1Xz0ktKr"> <div id="ad704-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad704" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad704",slotName:"wxix/web/sports/nfl/browns",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"YXYDB6KWFVEXJOH36P5UZYWFLI"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},
{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="f0G8x4vXz0ktKr"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> <li class=""> <a class="tag unstyled-link call-to-action uppercase bold unstyled-link tag-first" href="https://www.fox19.com/sports/nfl"> NFL </a> </li> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">Ex-Cleveland Browns lineman Greg Robinson caught with 157 pounds of marijuana near Mexico border, authorities say</h1> <h2 class="spaced spaced-xs spaced-top"></h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <img class="width-full " alt="Ex-Cleveland Browns lineman Greg Robinson caught with 157 pounds of marijuana near Mexico border, authorities say" src="https://www.fox19.com/resizer/nQRpyOT4Yy9qgmU2frXmIUlKJGI=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/F2F5CEEO6JCS7MQBJNGRXOYQQU.jpg"/> </div> <div class="container"> <figcaption class="caption-text spaced flex-container-row justify-space-between card card-article"> FILE - In this May 22, 2019, file photo, Cleveland Browns' Greg Robinson walks off the field during an NFL football organized team activity session at the team's training facility in Berea, Ohio. Browns starting left tackle Greg Robinson has re-signed with the team Monday, Sept. 2, 2019, a day after his contract was surprisingly terminated. (AP Photo/Ron Schwane, File) (Source: Ron Schwane) </figcaption> </div> </figure> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="c0qBKcXXz0ktKr"> <section id="article-sharebar" class="col col-no-gutter desktop-1 visible-lg spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share sharebar flex-container-column text-align-right"> <button class="social-icon spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=Ex-Cleveland+Browns+lineman+Greg+Robinson+caught+with+157+pounds+of+marijuana+near+Mexico+border%2C+authorities+say&amp;url=https%3A%2F%2Fwww.fox19.com%2F2020%2F02%2F20%2Fex-cleveland-browns-lineman-greg-robinson-caught-with-pounds-marijuana-near-mexico-border-authorities-say%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="fab fa-twitter social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> <button class="social-icon spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.fox19.com%2F2020%2F02%2F20%2Fex-cleveland-browns-lineman-greg-robinson-caught-with-pounds-marijuana-near-mexico-border-authorities-say%2F&amp;title=Ex-Cleveland+Browns+lineman+Greg+Robinson+caught+with+157+pounds+of+marijuana+near+Mexico+border%2C+authorities+say', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="fab fa-facebook-f social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> <a href="mailto:?subject=Ex-Cleveland%20Browns%20lineman%20Greg%20Robinson%20caught%20with%20157%20pounds%20of%20marijuana%20near%20Mexico%20border%2C%20authorities%20say&amp;body=Read%20more%20on%20Ex-Cleveland%20Browns%20lineman%20Greg%20Robinson%20caught%20with%20157%20pounds%20of%20marijuana%20near%20Mexico%20border%2C%20authorities%20say%20at%20https%3A%2F%2Fwww.fox19.com%2F2020%2F02%2F20%2Fex-cleveland-browns-lineman-greg-robinson-caught-with-pounds-marijuana-near-mexico-border-authorities-say%2F"> <button class="social-icon spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="far fa-envelope social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="f0z3yJ5Xz0ktKr"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> By <a class="color-blue hover-link" href="/authors/john-deike/"> <span class="font-bold ">John Deike</span></a> <span class="font-bold">|</span> <span class="timestamp"> February 19, 2020 at 9:46 PM EST - Updated February 20 at 7:28 AM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f0OiAz6Xz0ktKr"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>EL PASO, Texas (WOIO) - Former Cleveland Browns offensive lineman Greg Robinson and ex-NFL player Jaquan Bray were arrested near the El Paso-Mexico border on Monday evening, after authorities found 157 pounds of marijuana in an SUV the pair was traveling in.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Robinson, 27, and Bray, 26, were driving from Los Angeles, Calif. to Louisiana when they hit a border patrol checkpoint in El Paso, according to court documents.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>A drug-sniffing dog reportedly alerted authorities to the illegal drugs stashed in the 2020 Chevy Tahoe at the Sierra Blanca Checkpoint Station.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>A criminal complaint filed by U.S. attorneys alleges that Robinson and Bray were “conspiring to possess with intent to distribute marijuana.”</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad752-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad752" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad752",slotName:"wxix/web/sports/nfl/browns/YXYDB6KWFVEXJOH36P5UZYWFLI",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Authorities found the drugs in several large duffel bags stacked in the back of the SUV.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>The complaint also stated that Robinson rented the Tahoe in Los Angeles on Sunday and had arranged for an Uber driver to drive him and Bray to Louisiana. When the trio reached El Paso, Robinson instructed Bray to begin driving.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>According to the complaint, when they approached the Sierra Blanca checkpoint, Robinson asked the Uber driver to claim the marijuana, but they reportedly refused.</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad351-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad351" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad351",slotName:"wxix/web/sports/nfl/browns/YXYDB6KWFVEXJOH36P5UZYWFLI",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>If convicted, Robinson and Bray face up to 20 years in prison.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad854-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad854" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad854",slotName:"wxix/web/sports/nfl/browns/YXYDB6KWFVEXJOH36P5UZYWFLI",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Return to 19 News for updates on this developing story.</p> </div> </div> <div data-type="text" class="card collection-item card-border-bottom card-border-bottom-thick card-border-bottom-dark"> <div class="card-content card-article"> <p><i>Copyright 2020 WOIO. All rights reserved.</i></p> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-connatix" id="fwaAKx1Xz0ktKr"> <div class="flex-grid ad-connatix spaced spaced-lg spaced-top spaced-bottom "> <div class="col desktop-12 tablet-12 mobile-12"> <div id="connatix-highlights-embed" class="connatix-container box-shadow-light"></div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f06efnJXz0ktKr"> <div id="outbrain-article-ad" class=""> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="https://www.fox19.com/2020/02/20/ex-cleveland-browns-lineman-greg-robinson-caught-with-pounds-marijuana-near-mexican-border-authorities-say/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="https://www.fox19.com/2020/02/20/ex-cleveland-browns-lineman-greg-robinson-caught-with-pounds-marijuana-near-mexican-border-authorities-say/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-ads-arcads tablet-6 mobile-12 desktop-12" id="fzMDJM1Xz0ktKr"> <div id="ad101-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad101" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad101",slotName:"wxix/web/sports/nfl/browns",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"YXYDB6KWFVEXJOH36P5UZYWFLI"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-6 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="f47aum1Xz0ktKr"> <div class="invisible weather-gradient flex-grid color-white pb-weather day" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="day-clear" data-default-location-code="USOH0188" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="wxix" data-location-code="USOH0188" data-language="en" data-content-config-keys='Code,Language' data-content-config-values='USOH0188,en' data-custom-field-keys='spanish' data-custom-field-values=''/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="https://www.fox19.com/weather"> <img class="radar-image" src="//webpubcontent.raycommedia.com/wxix/Weather/RegionalSat_web.jpg" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="29" data-temp-c="-2"> 29</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/85_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in<br/>Cincinnati, OH</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="https://www.fox19.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast</button> </a> </div> </div> </div> </div> </div> <div class="flex-container-row justify-center spaced spaced-md spaced-bottom spaced-top font-semi-bold"> <span class="spaced spaced-right spaced-sm">Sponsored By</span> <div id="ad680-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad680" class="arcad ad-120x30"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad680",slotName:"wxix/web/weather-widget",adType:"weather-sponsorship",dimensions:"[[[120, 30]], [[120, 30]], [[120, 30]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"weather",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:false,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-article-author-bio" id="frRRQ42Xz0ktKr"> <div class="article-author-bio"> <div class="article-author-bio flex-grid flex-feature"> <h3 class="bold uppercase"> <span class="rectangle"></span> Author </h3> <div class="col desktop-12 tablet-6 mobile-12 height-full"> <div class="card skin"> <div class="card-media"> <div class="flex-grid"> <div class="flex-container-row "> <div class="flex spaced card-media flex-container-column justify-center flex-reverse spaced-left spaced-md"> <div data-type="image" class="author-bio author-bio-image card"> <figure class=""> <div class=" img-container aspect-ratio-3x2"> <img class="b-lazy width-full img-container" alt="John Deike" data-src="https://www.fox19.com/resizer/PFCWh9Ro0hbXviI0aOAoQjNEWuw=/1400x0/s3.amazonaws.com/arc-authors/raycom/5701432f-81fb-46ec-95d8-a114823e8ca0.png" src="https://www.fox19.com/resizer/cbrXpj4VRhicBLE8CbLs_CPa2Kg=/0x10/s3.amazonaws.com/arc-authors/raycom/5701432f-81fb-46ec-95d8-a114823e8ca0.png"/> </div> </figure> </div> </div> <div class="flex-2 flex-container-column justify-center"> <a class="spaced spaced-sm spaced-bottom" href="/authors/john-deike/"> <h3 class="promo-header">John Deike</h3> </a> <h4 class="spaced spaced-xs spaced-bottom font-normal color-grey-dark">Digital Content Producer</h4> <h4 class="spaced spaced-xs font-normal color-grey-dark">Cleveland, Ohio</h4> <span class="buttonbar buttonbar app-bar-share flex-container-grid width-full spaced spaced-sm spaced-top font-lg"> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" aria-label="Contact via email" href="mailto:jdeike@woio.com?subject=Ex-Cleveland%20Browns%20lineman%20Greg%20Robinson%20caught%20with%20157%20pounds%20of%20marijuana%20near%20Mexico%20border%2C%20authorities%20say&body=" role="button" rel="noopener noreferrer" data-arctrack="socialFollowEm"> <i class="far fa-envelope"></i> </a> </span> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-mailchimp-signup" id="fxwHfN1Xz0ktKr"> </div> <div class=" pb-layout-item pb-chain pb-c-single-chain full" id="c0NRdx1Xz0ktKr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fhr3sb2Xz0ktKr"> <div class="flex-feature "> <h3 class="bold"><span class="rectangle"></span> RECENT CONTENT</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-17784" data-content-service="content-feed"> </div> </div> </div> </div> </section> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f09JMK9Xz0ktKr"> <div id="ad1268-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1268" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1268",slotName:"wxix/web/sports/nfl/browns",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"YXYDB6KWFVEXJOH36P5UZYWFLI"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c008fu9Xz0ktKr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fmrOMh1Xz0ktKr"> <div class="flex-feature "> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-179862" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/02/04/joe-burrow-plans-spend-his-first-nfl-check-personal-chef/"> <img class="width-full " alt="Joe Burrow plans to spend his first NFL check on... a personal chef" src="https://www.fox19.com/resizer/3slZQ1YzpbYqUMZARPqYYRy1XrI=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/KYKADVFSEVFRJF7EOCSNHNSPSM.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/02/04/joe-burrow-plans-spend-his-first-nfl-check-personal-chef/"> Joe Burrow plans to spend his first NFL check on... a personal chef</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Garland Gillen</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published February 4, 2020 at 5:52 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/02/02/former-teammates-saw-it-coming-chiefs-kelce-you-knew-he-was-going-be-special/"> <img class="width-full " alt="Former teammates saw it coming for Chiefs’ Kelce: ‘You knew he was going to be special’ " src="https://www.fox19.com/resizer/cVHKr6cagf3mbxPI2LkgoUT7de4=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/SUS5AHGBTJBZVMM5ZCYD7ZZFOY.jpeg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/02/02/former-teammates-saw-it-coming-chiefs-kelce-you-knew-he-was-going-be-special/"> Former teammates saw it coming for Chiefs’ Kelce: ‘You knew he was going to be special’ </a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Joe Danneman</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published February 2, 2020 at 6:03 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/01/31/former-bengals-qb-carson-palmer-has-warning-joe-burrow/"> <img class="width-full " alt="Former Bengals QB Carson Palmer has a warning for Joe Burrow" src="https://www.fox19.com/resizer/6VK8D3HYYbb0UzGzS92N8_GgK3c=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/ZIPWGCZXARCVHKOD4DMZ7N77FQ.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/01/31/former-bengals-qb-carson-palmer-has-warning-joe-burrow/"> Former Bengals QB Carson Palmer has a warning for Joe Burrow</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>Dave Clark, Cincinnati Enquirer</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published January 31, 2020 at 2:26 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/01/30/bengals-promote-dan-pitcher-quarterbacks-coach/"> <img class="width-full " alt="Bengals promote Dan Pitcher to quarterbacks coach" src="https://www.fox19.com/resizer/WlVI6cOBgjFs4BXKIxS_atLCBds=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/ARMCJ5MCMJDIXJSLDYSSO7E34M.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/01/30/bengals-promote-dan-pitcher-quarterbacks-coach/"> Bengals promote Dan Pitcher to quarterbacks coach</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Jeremy Rauch</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published January 30, 2020 at 3:15 PM </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="pb-container"> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f0XShVkXz0ktKr"> <div id="ad345-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad345" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad345",slotName:"wxix/web/sports/nfl/browns",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"YXYDB6KWFVEXJOH36P5UZYWFLI"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},
{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="fU2oFF1Xz0ktKr"> <footer class="card card-dark"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.fox19.com"> <div class="logo logo-large logo-footer"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 635 West Seventh Street<br/> Cincinnati, Ohio 45203<br/>Main phone: (513) 421-1919<br/>Newsroom: (513) 421-0119<br/>Newsroom email: desk@fox19now.com </p> <a class="call-to-action uppercase color-white" href="http://www.fox19.com/about-us">About Fox19 Now <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div class="spaced spaced-top spaced-xl hidden-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/wxix-tv" class="color-white">FCC Public File</a></li> <li><a href="mailto:fox19questions@fox19now.com" class="color-white">fox19questions@fox19now.com<br/>513-562-2405</a></li> <li><a href="https://webpubcontent.raycommedia.com/wxix/2019-WXIX-EEOC-report.pdf" class="color-white">EEO Report</a></li> <li><a href="http://www.fox19.com/story/12032269/closed-captioning-problems/" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">WXIX Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/FOX19" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/FOX19Cincinnati" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://instagram.com/fox19now" target="_blank" role="button" aria-label="Visit Instagram" rel="noopener noreferrer"> <i class="fab fa-instagram "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl visible-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/wxix-tv" class="color-white">FCC Public File</a></li> <li><a href="mailto:fox19questions@fox19now.com" class="color-white">fox19questions@fox19now.com<br/>513-562-2405</a></li> <li><a href="https://webpubcontent.raycommedia.com/wxix/2019-WXIX-EEOC-report.pdf" class="color-white">EEO Report</a></li> <li><a href="http://www.fox19.com/story/12032269/closed-captioning-problems/" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">WXIX Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="visible-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/FOX19" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/FOX19Cincinnati" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://instagram.com/fox19now" target="_blank" role="button" aria-label="Visit Instagram" rel="noopener noreferrer"> <i class="fab fa-instagram "></i> </a> </span> </div> </div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/rHJ9vP1Xz0ktKr/render.js?v=89'></script> <script>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</script> <script>window.banditoEnv={TIMEOUT:1500,PERF_API:"https://bandito-events.perso.aws.arc.pub/api/save-perf",TESTS_API:"https://bandito.perso.aws.arc.pub/api/variants",EVENTS_API:"https://bandito-events.perso.aws.arc.pub/api/save-event"};if(window["pageBuilder"]&&window["pageBuilder"]["initVariants"])window.pageBuilder.initVariants({IS_ADMIN:false,TIMEOUT:window.banditoEnv.TIMEOUT,PERF_API:window.banditoEnv.PERF_API,TESTS_API:window.banditoEnv.TESTS_API,EVENTS_API:window.banditoEnv.EVENTS_API});</script> <script async src="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-index96cfbfc61ff908bdad44.js"></script>